Jump to content


Photo

Cannot Get Autodesk Generated Fbx To Display Properly?


  • Please log in to reply
2 replies to this topic

#1 fusionWannabe

fusionWannabe

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 525 posts

Posted 08 June 2011 - 05:28 PM

I've got an FBX created using the AutoDesk FBX 2012.1 Converter that should be identical to an FBX created with Lightwave 9.6.

However, it does not display the same.

In the first image, on the left is displayed the Autodesk FBX and on the right the Lightwave generated FBX with just the 'Light' enabled. The image on the left is very dark and the image on the right is displayed correctly.

In the second image, if I turn off 'Light', I can see that both are using the single image map with for their UVs.

The Autodesk FBX is FBX 2011, embed media, ASCII. But, I've tried 2012, not embedding, binary rather than ascii. Same problem with 2012.

For FBX 2006, 2009, 2010, Fusion 6.1 refuses to import the Autodesk generated FBX.

The Lightwave FBX is straight vanilla Lightwave 9.6 export.

I need to have it work with the Autodesk version, as I can automate the conversion of hundreds of frames, which I can't with Lightwave.

Any obvious clues as to how I can make both appear the same?

I've included the comp (using the Comp:\ so all the files are local).

Thanks!!!

Attached Files



#2 isotron

isotron

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 237 posts

Posted 09 June 2011 - 03:36 AM

looks like the Converter kills the vertex-normals. if u right click in the view -> 3dOptions-> show vertex normals u can see that the normals are missing ... but did not know the Converter and how to fix it there...

#3 fusionWannabe

fusionWannabe

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 525 posts

Posted 09 June 2011 - 09:57 AM

Isotron - thanks! That was the problem.

I tried MANY previous versions of the AutoDesk FBX converter

http://usa.autodesk....112&id=10775920

And found that if I used the 2011.2 AND converted to FBX 2011, no embed media, binary, that Fusion can read it and everything works.

Almost every version worked differently, AutoDesk must have great testing procedures!!!

So, problem solved!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users