Jump to content


Photo

Tried Everything In Fusion 6.4, It Simply Won't Work


  • Please log in to reply
26 replies to this topic

#1 Tom De Boefer

Tom De Boefer

    Member Pig

  • Adv Members
  • PipPip
  • 26 posts

Posted 11 November 2013 - 08:34 AM

And sorry it's a premultiply problem :-). In NUKE its works directly without changing a single option, but I prefer to use Fusion. I added a screenshot for comparison, also the source Fusion .comp is included.

I tried al the .settings related to this at vfxpedia, but the outlines remain. even with boolean operators..nothing works.

Can anyone open the comp file and have a look? The goal is to have the same result as in NUKE, so without the white outline.



Many many thanks!

screenshot url:
http://imageupper.co...501852480_1.jpg

Posted Image

Attached Files

  • Attached File  pot.zip   1.08MB   28 downloads


#2 iLuso

iLuso

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 88 posts

Posted 11 November 2013 - 09:05 AM

Hi Tom.
You can use MatteControl with gamma 0.45 and post multiply.

#3 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 11 November 2013 - 09:09 AM

The pot has edge pixels which are brighter than their corresponding alpha channels. This creates the bright edge when it's being merged. The reason it doesn't show up in Nuke is because the tif is in sRGB color space. Nuke removes the sRGB gamma when it reads the image, Fusion just reads the image as it is...

You can fix it in Fusion, but to me this looks like the tif is already slightly flawed. Alpha (un)premultiplication hasn't been done correctly when it was converted to sRGB.

Is that tif file coming from Fusion/Nuke or has it been rendered like that in a 3D app?


edit: ah, I see you've already found out :)

#4 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 11 November 2013 - 09:13 AM

Hi Tom.
You can use MatteControl with gamma 0.45 and post multiply.


that would break the alpha channel though...

#5 Tom De Boefer

Tom De Boefer

    Member Pig

  • Adv Members
  • PipPip
  • 26 posts

Posted 11 November 2013 - 09:23 AM

Tilt, it's a 3D render from 3ds max. Please tell me this is fixable :-)

#6 Tom De Boefer

Tom De Boefer

    Member Pig

  • Adv Members
  • PipPip
  • 26 posts

Posted 11 November 2013 - 09:29 AM

Hi Tom.
You can use MatteControl with gamma 0.45 and post multiply.

That gives a black border, am realy looking for a perfect solution, there must be way to do it properly in Fusion.

#7 redoddity

redoddity

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 190 posts

Posted 11 November 2013 - 09:52 AM

Probably a bit backwards, but going back to linear (without premultipication), and then back to sRGB( with premultiplication) works:

{
Tools = ordered() {
Merge1 = Merge {
Inputs = {
PerformDepthMerge = Input { Value = 0, },
Background = Input {
SourceOp = "Background1",
Source = "Output",
},
Foreground = Input {
SourceOp = "Gamut1_1",
Source = "Output",
},
},
ViewInfo = OperatorInfo { Pos = { 825, 346.5, }, },
},
Gamut1_1 = GamutConvert {
CtrlWZoom = false,
Inputs = {
OutputSpace = Input { Value = FuID { "sRGB", }, },
PreDividePostMultiply = Input { Value = 1, },
Input = Input {
SourceOp = "Gamut1",
Source = "Output",
},
},
ViewInfo = OperatorInfo { Pos = { 825, 313.5, }, },
},
Background1 = Background {
CurrentSettings = 2,
CustomData = {
Settings = {
[1] = {
Tools = ordered() {
Background1 = Background {
Inputs = {
Gradient = Input {
Value = Gradient {
Colors = {
[0] = { 0, 0, 0, 1, },
[1] = { 1, 1, 1, 1, },
},
},
},
TopLeftRed = Input { Value = 0.207843154668808, },
TopLeftBlue = Input { Value = 0.584313750267029, },
GlobalOut = Input { Value = 100, },
TopLeftGreen = Input { Value = 0.462745130062103, },
Height = Input { Value = 1556, },
Width = Input { Value = 2048, },
},
CtrlWZoom = false,
ViewInfo = OperatorInfo { Pos = { 569, 354, }, },
CustomData = {
},
},
},
},
},
},
Inputs = {
GlobalOut = Input { Value = 100, },
Width = Input { Value = 2048, },
Height = Input { Value = 1556, },
TopLeftRed = Input { Value = 0.505882352941176, },
TopLeftGreen = Input { Value = 0.717647058823529, },
TopLeftBlue = Input { Value = 0.819607843137255, },
Gradient = Input {
Value = Gradient {
Colors = {
[0] = { 0, 0, 0, 1, },
[1] = { 1, 1, 1, 1, },
},
},
},
},
ViewInfo = OperatorInfo {
Pos = { 715, 346.5, },
Flags = {
ShowName = true,
},
},
},
Gamut1 = GamutConvert {
Inputs = {
SourceSpace = Input { Value = FuID { "sRGB", }, },
Input = Input {
SourceOp = "Loader1",
Source = "Output",
},
},
ViewInfo = OperatorInfo { Pos = { 825, 280.5, }, },
},
Loader1 = Loader {
Clips = {
Clip {
ID = "Clip1",
Filename = "comp:\\pot.tif",
FormatID = "TiffFormat",
StartFrame = -1,
LengthSetManually = true,
TrimIn = 0,
TrimOut = 0,
ExtendFirst = 0,
ExtendLast = 0,
Loop = 0,
AspectMode = 0,
Depth = 0,
TimeCode = 0,
GlobalStart = 0,
GlobalEnd = 0,
},
},
Inputs = {
EnableClipList = Input { Value = 0, },
},
ViewInfo = OperatorInfo {
Pos = { 825, 181.5, },
Flags = {
ShowModes = true,
},
},
},
},
}


#8 redoddity

redoddity

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 190 posts

Posted 11 November 2013 - 09:55 AM

Also, is it an sRGB problem? or was the image rendered with a colored background? (Just checking, because if so, then a simple premultiply with color might work)

#9 Tom De Boefer

Tom De Boefer

    Member Pig

  • Adv Members
  • PipPip
  • 26 posts

Posted 11 November 2013 - 10:03 AM

Redoddity that is perfect! There is no more alpha but putting layers behind the pot does work, how is that possible? :mf_w00t2:

PS: It's rendered on black.

#10 redoddity

redoddity

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 190 posts

Posted 11 November 2013 - 10:11 AM

If it was rendered on black then it is as Tilt suggested, something odd in the gamma conversion and premultiplication.

#11 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 11 November 2013 - 12:57 PM

What do you mean by "there is no more alpha"? That the alpha channel has disappeared?! :glare:

#12 xmare

xmare

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 723 posts

Posted 11 November 2013 - 01:44 PM

just curious - a "post-multiply with alpha" in loader Import tab works for me...

#13 ChadCapeland

ChadCapeland

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,975 posts

Posted 11 November 2013 - 01:57 PM

just curious - a "post-multiply with alpha" in loader Import tab works for me...


It shouldn't. That setting assumes a linear image, which this is not.

- Chad

#14 Tom De Boefer

Tom De Boefer

    Member Pig

  • Adv Members
  • PipPip
  • 26 posts

Posted 12 November 2013 - 03:31 AM

What do you mean by "there is no more alpha"? That the alpha channel has disappeared?! :glare:


It did in my previous comp, when I applied a gamut, my alpha was completely white over the entire frame, but I was still able to put layers behind it. AFAIK it was just a viewport glitch because now it works like it should.

Also, when color correcting a single layer after the gamut I have to enable Pre Divide/Post Multiply in the CC options to avoid a small fringe. When enabled the result is perfect.

In Fusion 7 we'll be able to adjust an sRGB gamut in the loader itself, that's very good news.

#15 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 12 November 2013 - 04:53 AM

Also, when color correcting a single layer after the gamut I have to enable Pre Divide/Post Multiply in the CC options to avoid a small fringe. When enabled the result is perfect.


yes, that's how it has to be done.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users