Jump to content


Photo

Krokodove V6.00


  • Please log in to reply
27 replies to this topic

#1 Raf Schoenmaekers

Raf Schoenmaekers

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 85 posts

Posted 08 February 2014 - 09:58 AM

A new version of Krokodove is out now. Check out the website for more details: www.krokodove.com
(www.vimeo.com/channels/krokodove)

Have fun,
.raf

#2 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 09 February 2014 - 02:10 AM

cool stuff! I'll check it out. Can you tell us a bit what has changed in relation to the previous alpha release?

#3 Raf Schoenmaekers

Raf Schoenmaekers

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 85 posts

Posted 09 February 2014 - 06:09 AM

Most notably updates (to the user) I think are:
- Extended pen style options for shape tools
- Shape Boolean and Resample tools
- Some additions tot the Shape WriteOn tool

Underneath there's a whole new (my own) shape and outline rendering... allowing for plenty more stuff to come.
I'll try and keep track better of what I do so I can document better in the future. But I'm also working on some showcase videos... which should set you on the right track as well.

Regards,

.raf

#4 Dunn

Dunn

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 303 posts

Posted 09 February 2014 - 06:53 PM

Wow, nice Update on the Shape tools! ;)
I like the new Pen Style options ..cool, now we can do crawing ants around images, :mf_dribble: Yeah! ( hehe )

#5 savat

savat

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 80 posts

Posted 10 February 2014 - 06:13 AM

Raf,

please please...create an online guide

#6 Pilalitos

Pilalitos

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 791 posts

Posted 14 February 2014 - 08:54 AM

OK I had some time to check the update today and the shape additions rock! Great tool Raf!

I noticed the PASS THROUGH doesn't work with the sOffset tool. I had a sTraceCreate>sOffset>sRender flow and when PASS THROUGH was set for sOffset the shapes just vanished.

:)

#7 ChadCapeland

ChadCapeland

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,975 posts

Posted 17 February 2014 - 10:18 PM

Having fun with the shape tools. Something I'm noticing, though, is that the sRender assumes that the image aspect is 1.77777... Anything else and the shapes don't line up with their transforms. So an sPrimativeCreate will make the shape in the correct aspect, but it won't be aligned to it's TransformPosition.

Couple things I'd like to see though... an sReverse so that I can change the direction of the stroke for sWriteOn, and some sort of enable/disable or ID based passthrough for sShading so I can affect some of the parameters, but not override them all.

Also, getting a line segment proved to be a bit of a challenge. I managed to get it, but it was a bit trickier than I was expecting. :)

It would also be nice if the PenThicknessBias affected the Brush as well. In case I want to offset the brush (without a pen) so that it exactly lines up with the pen (without a brush).

#8 Raf Schoenmaekers

Raf Schoenmaekers

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 85 posts

Posted 18 February 2014 - 02:08 PM

Having fun with the shape tools. Something I'm noticing, though, is that the sRender assumes that the image aspect is 1.77777... Anything else and the shapes don't line up with their transforms. So an sPrimativeCreate will make the shape in the correct aspect, but it won't be aligned to it's TransformPosition.
Couple things I'd like to see though... an sReverse so that I can change the direction of the stroke for sWriteOn, and some sort of enable/disable or ID based passthrough for sShading so I can affect some of the parameters, but not override them all.
Also, getting a line segment proved to be a bit of a challenge. I managed to get it, but it was a bit trickier than I was expecting. :)
It would also be nice if the PenThicknessBias affected the Brush as well. In case I want to offset the brush (without a pen) so that it exactly lines up with the pen (without a brush).


A few answers:
- The frameaspect can be set in the Transform tab. Though there is a 'Automatic' button... it currently is always 'Manual'. Working on this.
- sReverse will be sTool, and will allow for reverse, force close, shift starting point, order shapes (according to their leftmost/center/average/etc point). Almost done.
- I'm currently deciding on the best way to work on a selection of shapes only. Named groups? Sets (like particles)? Shape Masks? All of them (most likely)?
- Segments. I've added to sWriteon a "clip to full segment" option. Done
- PenThicknessBias vs Brush. I'll see what I can do...

But now first: sLoader (svg) and sText:-)
.raf

#9 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 18 February 2014 - 02:54 PM

Couple more weeks and then I'll have time to play... couple more weeks...

:)

#10 ChadCapeland

ChadCapeland

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,975 posts

Posted 19 February 2014 - 12:53 PM

I see about the transform aspect... So "Automatic" would use the sRender that's requesting it?

For sets, I like how clean the Object and Material ID's are in the 3D system. A slider or range with the ability to change the IDs of a portion of a stream via Override3D.

For segment I just meant I wanted a point-to-point line segment. In my shot, I was connecting sPrimativeCreates with connecting lines, ended up using a sSpiralCreate with the AngleEnd = AngleStart. It's neat how you could make a curved connection by setting AngleEnd to be ==AngleStart+10, though.

Something I did have to do, though, for sWriteOn was fiddle with the keyframes because with Global the range control is normalized to the total length of all the shapes. It would be cool to normalize it to the number of shapes. So that way I could animate the first shape writing on, then the second, then the third by just keyframing the number to 1/3, 2/3, 3/3, even if my shapes are animated and change length (or I decide to change the shapes later and now my animation is off). The values between the "notches" would normalize to the length of the second shape. You could also just set the upper bound for the number to be the number of shapes, so it would be 0.0 - 3.0 in this example. I know Fusion's number controls can be a bit weird on rescaling in the UI, but it's an option, especially when you have say 23 shapes and can't remember what 17/23 is as a decimal. :)

The PenThicknessBias vs Brush was worked around by turning on the brush, but setting the color to 0,0,0,0.

Oh, how about letting us use Fusion's polylines? Then we can draw whatever we want using a Ply or Bsp or using any of the other tools that generate them? May handle your SVG import needs that way, too.

- Chad

#11 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 20 February 2014 - 10:15 PM

Couldn't resist just going through it :)

Soooooo promising. This really is a great release!

Just at first glance it seems I can't get colour to work in the shapes though. Opacity works, but only that, so nothing but shades of grey for me. Luckily more than 50 :)

Thanks Raf!

#12 Raf Schoenmaekers

Raf Schoenmaekers

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 85 posts

Posted 21 February 2014 - 08:18 AM

Just at first glance it seems I can't get colour to work in the shapes though. Opacity works, but only that, so nothing but shades of grey for me. Luckily more than 50 :)


That's (very) odd... Could it be you're looking at only one of the RGB channels?
Though I wouldn't expect this kind of beginners mistake from you? :-)
.raf

#13 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 21 February 2014 - 12:41 PM

:)

Nope, that was the first thing I checked. Also in that case changing the colour would still influence my result. The brush colour is always white in my case.

Win8, Fu64. Will try a reboot of the whole system later.

#14 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 22 February 2014 - 10:20 PM

Rebooted, tried again, but no luck. Colour controls don't work, opacity controls do.

Next step is to try on a different machine...

#15 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 22 February 2014 - 10:33 PM

Hmm... different machine, same deal. This time Win7. Fu64 build 1118.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users