Jump to content


Photo

New Fusion Feature: Launching Scripts From Custom Buttons!


  • Please log in to reply
17 replies to this topic

#1 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 05 July 2014 - 04:20 PM

Posted Image

Woooooo look at that! :)

OK - this is really quick and dirty but it works for me. I took some snippets of code from Bartos P.'s Track_one_frame script and added two buttons in the tracker.

Unzip the Tracker.zip file into your scripts:/Comp location. It will add a subdir called Tracker.

This is fun!

OK Tilt, now how can we spawn transform nodes that either matchmove or stabilize, taking into account a reference frame set via a slider? :)

Attached Files



#2 xmare

xmare

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 723 posts

Posted 05 July 2014 - 04:31 PM

dont forget Update pattern script! :)
and why is it tracker plus? it's not "a standard tracker"?.......

#3 SecondMan

SecondMan

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 1,797 posts

Posted 05 July 2014 - 04:41 PM

You can name it anything you like. I just randomly named this example TrackerPlus because I added something to the Tracker. :)

#4 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 06 July 2014 - 02:06 AM

So... quick test...

The code in BTNCS_Execute *has* access to the tool variable! You can even write multi-line LUA code. Even print a new-line character with some additional escaping.
I need to try python... there was some funky keyword that Blazej once posted that switches the interpreter to Python mode...


{
Tools = ordered() {
  TestBlur = Blur {
   NameSet = true,
   UserControls = ordered() {
    TestButton = {
	 LINKID_DataType = "Number",
	 INP_External = false,
	 LINKS_Name = "Test BTNCS_Execute",
	 BTNCS_Execute = "print(\"\\nI am:\")\nprint(tool)",
	 INPID_InputControl = "ButtonControl",
	 IC_ControlPage = 0,
    },
   },
  },
},
}


#5 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 06 July 2014 - 03:09 AM

oh why must every nice thing about Fusion be offset by suck? In the latest build, the viewers aren't drawn anymore and context menus no longer work. :mf_tongue:

#6 bfloch

bfloch

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 960 posts

Posted 06 July 2014 - 03:10 PM

Sweet! That sure is a cool feature! Have been waiting for this!

#7 bfloch

bfloch

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 960 posts

Posted 06 July 2014 - 03:35 PM

oh why must every nice thing about Fusion be offset by suck?

I guess the answer is because Fusion's user base is impatient :-)

#8 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 06 July 2014 - 04:18 PM


oh why must every nice thing about Fusion be offset by suck?

I guess the answer is because Fusion's user base is impatient :-)


I've received word from the devs and apparently my Parallels on Mac is no longer able to run Fusion due to some dll memory limit or something. I don't have the latest Parallels so maybe there's hope. But for now... no more video tutorials.

Booting into Windows and everything' runs fine. But now my graphics card is no longer a valid OpenCL device for Fusion. Well.. time to buy a new system. Or stay with 6.4... great.

#9 bfloch

bfloch

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 960 posts

Posted 06 July 2014 - 04:44 PM

Sounds bad. The OpenCL part is strange. Isn't bootcamp running regular gfx drivers? Did you try updating drivers?

As to parallels: Probably best to ask their customer support as well or evaluate a new version.

I remember when you got the Mac in Düsseldorf - Laut afa tabelle bereits abgeschrieben? ;-)

#10 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 07 July 2014 - 12:51 AM

Sounds bad. The OpenCL part is strange. Isn't bootcamp running regular gfx drivers? Did you try updating drivers?

Apple apparently hasn't supplied updated bootcamp drivers but I'll see what's on the nvidia website.

As to parallels: Probably best to ask their customer support as well or evaluate a new version.

Good idea!

I remember when you got the Mac in Düsseldorf - Laut afa tabelle bereits abgeschrieben? ;-)

Haha, yeah. How time flies! Time for a new one. But on the other hand I was hoping to chug along with the old macbook and spend that money on baby stuff instead :-)

#11 Dunn

Dunn

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 303 posts

Posted 07 July 2014 - 01:54 PM

....But on the other hand I was hoping to chug along with the old macbook and spend that money on baby stuff instead :-)


Wise choice! :huh: Greetings to your family :mf_prop:

#12 xmare

xmare

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 723 posts

Posted 07 July 2014 - 03:05 PM

@Tilt
from my expierience - go buy a new one while You still can!! ;)
my second has 2month's - and it's the last moment for me - i'm trying to swap my dell to clevo ;D

#13 bfloch

bfloch

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 960 posts

Posted 07 July 2014 - 04:40 PM

Haha, yeah. How time flies! Time for a new one. But on the other hand I was hoping to chug along with the old macbook and spend that money on baby stuff instead :-)


Like an iPad Mini? :-)


#14 Tilt

Tilt

    Flying Pig

  • Adv Members
  • PipPipPipPipPip
  • 2,137 posts

Posted 11 July 2014 - 03:30 PM

As to parallels: Probably best to ask their customer support as well or evaluate a new version.


Good news for everybody running Parallels on Mac: I've updated to version 9 and Fusion works again :-)

#15 nightwolf1985

nightwolf1985
  • Adv Members
  • 1 posts

Posted 29 August 2014 - 08:15 AM

not work by me copy tracker folder to

Documents\eyeon\Fusion\Scripts\Comp

and TrackerPlus.setting to Documents\eyeon\Fusion\Macros

load trackerplus in fusion 6 klick TrackOneFrameBackward no frame track :(




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users